Table of Contents

1 About This Guide ................................................................................................................. 4
2 Printing Statler Patterns ........................................................................................................ 5
   2.1 Printing Pattern Files with Windows XP ............................................................................... 5
2.2 Printing a Single Pattern with AutoSketch ........................................................................... 5
2.3 Printing a Single Pattern with AutoSketch ........................................................................... 5
3 AutoSketch Screen Features ................................................................................................ 6
   3.1 Title Bar .............................................................................................................................. 6
   3.2 Menu Bar ............................................................................................................................ 6
   3.3 Edit Bar .............................................................................................................................. 6
   3.4 Customize Your Toolbar .................................................................................................... 6
4 Navigating the Drawing Board .............................................................................................. 8
   5.1 Grid ...................................................................................................................................... 8
   5.2 Guidelines .......................................................................................................................... 8
   5.3 Full Screen Cursor ............................................................................................................. 8
   5.4 Entities ................................................................................................................................ 8
   5.5 Select .................................................................................................................................. 8
   5.6 Zooming In (Out) ............................................................................................................... 9
   5.7 Pan Realtime ...................................................................................................................... 9
   5.8 Endpoint Snap ................................................................................................................... 9
   5.9 Grid Snap .......................................................................................................................... 9
   5.10 Measuring Drawings .......................................................................................................... 9
   5.11 Calculator ........................................................................................................................ 9
5 Drawing Patterns .................................................................................................................... 10
   5.12 3-Point Arc ...................................................................................................................... 10
   5.13 Polyline and Line Single ................................................................................................. 10
   5.14 Vertex Editing .................................................................................................................. 10
6 Using Guidelines and Editing the Drawing ............................................................................ 11
   6.1 Transform Rotate ............................................................................................................... 11
   6.2 Transform Mirror .............................................................................................................. 12
   6.3 Transform Scale ............................................................................................................... 12
   6.4 Rubber Stamp .................................................................................................................. 12
   6.5 Circular Array ................................................................................................................... 13
Make the Pattern Continuous .................................................................................................. 14
   6.6 Trim Tools ......................................................................................................................... 14
   6.7 Explode ................................................................................................................................ 14
Add Instructions to Drawing ..................................................................................................... 15
   6.8 Adding Text ....................................................................................................................... 15
   6.9 First and Last .................................................................................................................... 15
   6.10 Ordering Intersections .................................................................................................... 16
   6.11 Snap Distance ............................................................................................................... 17
7 Files .......................................................................................................................................... 18
9 Opening Errors ...................................................................................................................... 19
   9.1 File Opens but Drawing is Not Correct ............................................................................ 19
   9.2 Endpoint Connection Error ............................................................................................. 20
   9.3 Ordering Error ................................................................................................................. 20
   9.4 No "First" Error ................................................................................................................. 20
10 Single Patterns ..................................................................................................................... 21
Repeat Patterns ........................................................................................................................ 21
12 Alternating Patterns .......................................................................................................................... 22
13 No Sew Move and Pause in Pattern .................................................................................................. 23
  13.1 Patterns ........................................................................................................................................ 23
  13.2 Text ................................................................................................................................................ 24
  13.3 Pause ............................................................................................................................................ 24
15 Importing Windows™ Metafiles (WMF Files) ............................................................................. 25
  15.1 Opening WMF files in AutoSketch ............................................................................................... 25
  15.2 Copying WMF Files from Other Applications ............................................................................. 25
16 Closed Shapes .................................................................................................................................. 26
17 Tracing Pictures ............................................................................................................................... 27
  17.1 Using Layers .................................................................................................................................. 27
  17.2 Tracing Directly on the Picture .................................................................................................... 27
18 Threading the Machine ..................................................................................................................... 28
  18.1 Gammill Quilting Machine Using Cone ....................................................................................... 28
  18.2 Gammill Quilting Machine Using Small Spool ........................................................................... 29
19 Engaging and Disengaging the Belts ............................................................................................... 30
  19.1 Engaging the Belts ....................................................................................................................... 30
  19.2 Disengaging the Belts .................................................................................................................... 30

3
### 1 About This Guide

AutoSketch is a powerful drawing program designed for simple to the most advanced drawing applications. The scope of this user guide is limited to using the tools and features of AutoSketch to draw patterns to be used with the Statler Stitcher™ Quilting System. Additionally, this user guide pertains to the PrecisionStitch™ software and assumes the user is familiar with Windows™ operating system.

A good source for basic information on using AutoSketch is the **Getting Started** book included with the program. You should read this book thoroughly, going through the Two-Minute Tutorials to become comfortable navigating and using the screens and menus. The Help files in the software contain detailed information. To search the help files using keywords click **Help > AutoSketch Help > Index**.

Files should be saved every few minutes as you are drawing or making changes. In case of a power loss or computer hiccup you have a recent version saved. The DXF version of the file should be saved only when you are ready open the file to stitch the pattern.

When the DXF file is opened in PrecisionStitch™ the program automatically builds it for stitching. The build function is invisible to the user.

The basic steps used to create Statler Stitcher pattern files (DXF files) from AutoSketch are:

1. Draw the pattern and save as an SKF file.
2. Make sure the drawing is one continuous line, connecting the endpoints.
3. "Explode" the drawing.
4. Label the "first" and "last endpoints and add additional text as needed.
5. Save as a DXF file. You might also prefer to save a picture version of the drawing as a WMF file that can be printed later. See **Printing Statler Patterns**.
6. If errors occur during the build process, edit the SKF file and save as a DXF file to be used in the second attempt.

---

4
2 Printing Statler Patterns

You might want to print paper copies of Statler patterns to show clients. This information is reprinted here by permission from Glenn Hall in Texas. Patterns are stored in three graphic file types on your computer:

- AutoSketch standard format: (filename).skf, Example: "apple.skf"
- AutoSketch format: (filename).dxf
- Example: "apple.dxf"
- Windows metafile in the form of (filename).wmf, Example: "apple.wmf"

Using Windows Explorer, navigate to the directory where the pattern files are located. Under View select Detail. The skf files can be viewed in AutoSketch as well.

2.1 Printing Pattern Files with Windows XP

This process is a little long but it is easy and well worth the effort since it prints 35 patterns per page.

1. Right click on the Windows Start button then click Explorer.
2. Look for a folder called Pattern 2002 or whatever folder your files are in.
3. Double click on the folder.
4. Look for the wmf files and right click on the first wmf file. Select Open With Windows Picture and Fax Viewer.
5. Click on the printer icon just below the pattern.
6. Click Next > Select All > Next.
7. Select Printer using the box at the top of the page.
8. Click Next (the computer will complain about the size of the patterns, but ignore it).
9. Click Continue.
10. Select Contact Sheet (prints 35 patterns per page).
11. Click Next, printing should start.

2.2 Printing a Single Pattern with AutoSketch

In AutoSketch you can only print one pattern per page. When you first open these patterns in AutoSketch 8.0 you can't see the pattern but this is not a problem.

1. Click File > Open.
2. Go to the Pattern SKF folder and select the pattern you want to print.
3. Click Tools > Drawing Options.
4. Click Scale then AutoFit at the bottom of the page. Click OK.
5. Click File > Print Preview.
6. Select Fit to Printed Page.
7. Select or deselect Grid (prints grid on the patterns).
8. To check once again before printing, click Print > Print Preview.
9. Click Print > OK.

2.3 Printing a Single Pattern with AutoSketch

In AutoSketch you can only print one pattern per page. When you first open these patterns in AutoSketch 8.0 you can't see the pattern but this is not a problem.

1. Click File > Open.
2. Go to the Pattern SKF folder and select the pattern you want to print.
3. Click Tools > Drawing Options.
4. Click Scale then AutoFit at the bottom of the page. Click OK.
5. Click File > Print Preview.
6. Select Fit to Printed Page.
7. Select or deselect Grid (prints grid on the patterns).
8. To check once again before printing, click Print > Print Preview.
9. Click Print > OK.
3  AutoSketch Screen Features

3.1 Title Bar

The Title Bar displays the name of the program and the name of the current drawing file, in this case, Flower.

3.2 Menu Bar

The menu bar is used to access most of the features of the program. Clicking on the word displays the options available on that menu.

3.3 Edit Bar

The Edit Bar pops up when certain features are selected. This is an example of the Edit Guidelines edit bar.

3.4 Customize Your Toolbar

To customize your toolbar with the features you use most often:

- Click View>Toolbars to open the Toolbars menu.
- Click New to display the New Toolbar menu.
- Type in the name of your custom toolbar and click OK.
- Choose the features on the right and drag them into the left side of the screen. You can arrange the icons in the order you wish to display them.
- Click Close. The new toolbar is shown on the screen. Click and drag the toolbar to the location of your choice, either on the screen or into the upper or side areas.

The choices I recommend for your custom tool bar are:

- Select Direct
- 3 Point Arc
- Single Polyline
- Line Single
- Edit Guideline
- Endpoint Snap
- Gridpoint Snap
- Snap Off
- Rubber Stamp
- Circular Array
- Mirror
- Zoom In
- View Page
- View Extent
- Pan Realtime
- Trim Join
- Explode
- Text Point
5  Navigating the Drawing Board

The AutoSketch drawing board has options and features that help you draw faster and more accurately. These features are not seen when the drawing is printed or the pattern is stitched. By becoming familiar with these features you are able to quickly and efficiently draw even the most complex patterns.

5.1 Grid
Reference grids are used for visual reference for drawing only and are not printed. The three types of reference grids are rectangular, circular and isometric. You will use the rectangular grid most often and sometimes the circular grid. Isometric grids are for three dimensional drawings and should not be used for pattern drawing. Set up or change the reference grid by clicking Tools > Drawing Options > Grid.

You might find it helpful to set up a grid in 1" increments that is 14" high by 30" wide. The extra 2" in height gives a little extra room for drawing.

5.2 Guidelines
Guidelines are lines or circles that you place on your drawing to use as boundaries or guides when drawing. Guidelines are saved as part of the drawing but since they are not drawing entities, they are not printed. You might find it helpful to change the appearance of guidelines to distinguish them from gridlines. Control the appearance of guidelines by clicking View > Options > Appearance.

1 Click the edit guidelines icon to add or delete guidelines on your drawing. The guidelines edit bar appears.

2 Choose the horizontal, vertical or diagonal guideline icon to place a guideline on the drawing board. If snaps are enabled, the guideline will snap to the grid or drawing.

3 Click X to delete single guidelines or click to delete all guidelines.

5.3 Full Screen Cursor
The full screen cursor turns the cursor into crosshairs when or tools entities are selected. As these cross hairs cross guidelines or entities the colors change. This feature is useful when measuring and scaling patterns and when placing guidelines. To set the full screen cursor, right click on the drawing board and select Drawing Options. Click the Drawing tab then check Full Screen Cursor on the right side near the middle of the screen.

5.4 Entities
An entity is a single object in a drawing. Lines and polylines are basic entities. When you group one or more basic entities together using the group icon, you create a compound entity. For purposes of drawing for Statler Stitcher patterns, you should avoid using the group icon to group drawing entities. Resizing grouped entities creates spaces between endpoints. Instead, use the Trim > Join function to join endpoints then resize the joined entities using the scale tool. The drawing must be exploded before converting to a QLI file.

5.5 Select
Use the Select icon to select entities to edit. When an entity is selected, green selection handles appear around the entity and a yellow diamond appears at the center as shown below.

The green pointed handles reduce or enlarge the entity only in the direction it points. The green squares reduce or enlarge the entity while keeping the height and width proportions (scale) the same. The blue arrow and handle is the rotation handle and is used to rotate the entity. When resizing an entity you
might find it easier to turn off the snaps, otherwise the drawing will snap to endpoints or gridlines, limiting the scaling to increments.

5.6 Zooming In (Out)
Using the mouse or the keyboard you can get a closer look at an area or see a larger portion of the drawing by zooming in or out. This is important when drawing patterns and adding text such as "first" and "last" as well as numbering or ordering the stitching path.

1. Click View > Zoom In (Zoom Out) or click the Zoom In (Zoom Out) button on the toolbar.
2. Click and drag from one corner of the area you want to enlarge, to the opposite corner, or
3. Click in the drawing window.

A quick way to zoom in or out, if available, is to use the scroll wheel of the mouse.

5.7 Pan Realtime
The Pan icon is helpful when moving around the screen without deselecting entities. This feature moves the drawing window to see portions of the drawing which are outside the current view.

1. Click View > Pan Realtime or click the Pan Realtime button on the toolbar.
2. Click and drag to move the window in the desired direction.

You can also pan without selecting the pan tool by using the roller on your mouse. Press the roller and move the mouse to move the drawing pad around the screen. Using the mouse to pan means you do not deselect entities.

5.8 Endpoint Snap
The curved and straight line segments you use to draw patterns must be continuous and connected. The endpoint snap ensures that the endpoints of the various parts of your design snap to connect. If you are drawing a multiple pattern such as a pantograph, the beginning and end points must lie along the same horizontal grid line.

Click the endpoint snap icon or press the "E" key to toggle the endpoint snap off and on. Turn off all other snaps such as Jump Snap, Center Snap and Perpendicular Snap. A quick way to do this is to click Tools > Drawing Options then click the Drawing tab. Check Endpoint and uncheck all other Active Snaps. Click Save as Default if you want this set up for each new file you open.

5.9 Grid Snap
Click the grid point Snap icon or press the "G" key to toggle the grid point snap. This snap is useful if you want to align your drawing to the grid. As you move your curser in the drawing, an auto point indicator, a red dot, identifies the nearest grid point. At times you might find it useful to turn off all the snaps.

5.10 Measuring Drawings
Use this tool to measure from one point to another. Set the cursor to Full Screen Cursor. This is useful because when the crosshairs cross parts of drawings the crosshairs change color. When needed, use snaps to precisely place the cursor at the measuring points.

1. Choose Inquire > Distance from the menu.
2. Move the cursor to the first measuring point and left click.
3. Move the cursor to the second measuring point and left click again.
4. The Distance screen is displayed with values for the Measured Distance, Delta-x and Delta-y.

5.11 Calculator
If you need a calculator you can choose the calculator tool or press =. Enter the equation and click Evaluate to display the results. Use the * key for multiplication.
The steps to complete an AutoSketch drawing for the Statler Stitcher include:

1. Sketch and Edit the Pattern using the drawing tools
   a. 3-point arc
   b. Polyline and Line Single
   c. Vertices
   d. Rotate, Mirror, Scale and Rubber Stamp
   e. Ring Array

2. Make the Pattern Continuous
   a. Connect endpoints with Trim-Join
   b. Explode

3. Order the Drawing
   a. First and Last
   b. Order the Intersections
   c. Snap Distance

4. Save as DXF. Save as WMF if a picture file is desired.

5.123-Point Arc
Click the 3-point arc icon to draw curves. Click where you want the arc to begin then click where you want the arc to end. Hold down the CTRL key to edit the curve of the arc then click to complete the arc.

5.13Polyline and Line Single
Click the polyline to draw multiple, connected line segments. The Line Single tool lets you draw straight lines between points. Click where you want the line to start then click where you want the line to end. Right click to end the line.

5.14Vertex Editing
Each entity is made up of two or more vertices. Vertices are points between which segments are drawn or a curve is generated. For example a line has two vertices, one at each end. The line is drawn between these two vertices. Instead of a straight line, some polyline entities will generate a curve between the vertices.

To display the vertices of an entity, double click on the entity. You can also select the entity and click the edit vertices icon. You will see the vertices as a series of green squares connected by lines or curves. Vertices can be added, deleted, designated as endpoints, moved etc.
6 Using Guidelines and Editing the Drawing

In the picture below the guidelines are shown as red dashed lines. The leftmost point of the drawing, first, is positioned on the horizontal guideline. The rightmost point of the drawing, last, is near the horizontal guideline but not on it. The vertical guideline designates the rightmost boundary for this pattern.

Zoom in on the "last" area of the pattern including the intersection of the guidelines. Double click the line to enter the Edit Verticies mode. The picture below is a close up of the last three vertices of the drawing. We want the last vertex to be positioned at the intersection of the red guidelines.

At this point you can either add a polyline to extend the line to the intersection of the guidelines or you can extend the drawing to the intersection of the guidelines by moving the endpoint.

To add a polyline – with endpoint snap turned on, click the Line Single icon. Start the line at the last vertex and end it at the intersection of the guidelines. The result is shown below.

Move the Vertex
An easier way to extend the line is to simply click and drag the endpoint vertex to the intersection of the guidelines.

6.1 Transform Rotate
There are several ways to rotate an entity or set of entities:

Keyboard
1. Select the entity or entities to rotate.
2. Use the plus (+) and minus (-) keys on the numeric keypad, or the F5 and SHIFT+F5 keys to rotate the selection set.
Rotation Handle
Click and drag the rotation handle. The selection rotates at the increments set in the drawing options menu.

6.2 Transform Mirror
To mirror entities across a line you specify
1. Place a guideline along the entity to designate the mirror point.
2. Select the entity or entities to mirror.
3. Click **Edit > Transform > Mirror** or click the Mirror button on the toolbar.
4. If you want to mirror a copy and leave the original, check the Copy or Move check box on the edit bar.
5. Click near one end of the guideline then click near the other end of the guideline. A mirror image of the entity is copied or moved.

Often after entities are mirrored you may not be able to connect the end points. If you use **Trim–Join** to join the entities before mirroring them you will not have this problem. Be sure to Explode the drawing after you mirror it. Another way to prevent the endpoints from not connecting is to save and close the file then reopen it. You should now be able to snap the endpoints.

6.3 Transform Scale
The scale tool is used to scale an entity or selection set of entities to a smaller or larger size. Another tool, the calculator, is used with the scale tool to obtain exact results. Use the following steps to scale an entity or selection set of entities.

1. Measure the pattern height (see Measuring Drawings).
2. Open the calculator screen by clicking the calculator icon from the toolbar.
3. In the Enter expression field insert the scaling calculation which is What You Want / What You Have. For example if you want the height to be 12" and the measured height is 6.893" the scaling calculation is 12 / 6.893 and click Evaluate. The result is 1.740...
4. Click **Copy** to copy the result then **Close** to close the calculator.
5. Use **Edit>Select>All** to select all the entities.
6. Click the scale icon. In the scale property bar highlight the scaling factor and right click on it. Choose Paste text to paste the result.
7. Click once on the drawing board.

In step 3 above the scaling calculation works for enlarging and reducing the pattern size. Remember it is always **What You Want** divided by **What You Have**.

6.4 Rubber Stamp
If you have an entity that you want to repeat several times in the pattern, use the rubber stamp tool to quickly duplicate and position these copies. Select the entity, right click then click **Rubber Stamp**. Alternatively you may select the entity then click the rubber stamp icon on the toolbar.

A duplicate of the entity appears and moves with the cursor. Click to place the copy. You can continue clicking to place as many copies as you like. Right click to stop rubber stamping. An excellent use of the rubber stamp feature is to see how patterns look when repeated and placed together such as borders and pantographs. When you are satisfied with the appearance of the repeated pattern you can save a copy of the file as a WMF file. Use this WMF file to print a picture of the pattern for your clients. The picture top right shows one copy of BORDE11 at the top and four rubber stamps at the bottom.
6.5 Circular Array

Block patterns are quick and easy to create using the circular array. You simply draw one part of the pattern, such as \( \frac{1}{4} \) or \( \frac{1}{8} \) then use circular array to place repeats in a circle.

Draw one vertical, one horizontal and one diagonal guideline as shown below left. Draw one portion of the pattern between any two guidelines. The picture below shows the drawing placed between the vertical and diagonal guidelines to make up \( \frac{1}{8} \) of the drawing.

The pattern was drawn using one two three-point arcs snapped to the guidelines. Notice that the drawing does not end at the intersection of the guidelines. This makes it easier to connect the endpoints later.

Select all the entities and click the circular array icon to display the Circular Array menu. Under Angular Duplication select 7 copies at 45°. Click OK. The curser changes to a circle with outside crosshairs. Snap the curser to the intersection of the guidelines and click. This location represents the center of the soon-to-be formed circular array. You now have 7 copies of the drawing centered at the guideline intersection as shown below.

If you wanted to make more or less copies in the array, calculate the angle as follows:

\[
\frac{360°}{(\text{number of copies} + 1)}
\]

Now zoom into the center of the drawing to connect the endpoints and complete the other steps for preparing the pattern.
Make the Pattern Continuous

Patterns for the Statler Stitcher must be continuous and all the endpoints must connect. To check for these connections use the Trim-Join feature. Once you have checked that all the endpoints are joined you must remember to explode the drawing before proceeding to the build function.

6.6 Trim Tools

Trim – Join

The Join feature is useful when checking a drawing for endpoint connects. If you are using Join to check that all endpoints are connected, you should explode the drawing before saving it as a DXF file for conversion. To join two entities sharing a common endpoint location:

1. Click Edit > Trim > Join or click the Join button on the toolbar.
2. Press the CTRL key and click the first entity to join all connecting entities.
3. Check to see if all the entities are joined by clicking the Select icon then clicking on the first entity. All the entities should be selected if all the endpoints are joined.

Two ways to trim an entity are the Trim Break and Trim Cannel features. Removing a section from an entity, either by breaking or channeling, results in two separate entities which can be selected or edited independently.

Trim Break

This feature creates a gap in an entity by clicking a single point at the center of the gap. Use this feature to remove a section from an entity or to break open a closed entity.

1. Click Edit > Trim > Break, or click the Break button on the toolbar.
2. Click on the entity you want to break.
3. Click the point where you want to break. This point becomes the center of the break. A section of the entity is gone.

Trim Channel

Channel creates a trimming path that removes sections from one or more entities. To cut a channel through one or more entities:

1. Click Edit > Trim > Channel or click the Channel button on the toolbar.
2. Click the two points that define the channel. Dashed lines illustrate the channel path.
3. Click on the parts of the entity inside the channel to delete.

6.7 Explode

This feature explodes entities to their smallest components, allowing you to edit the individual components of an entity. To explode, select the entity or entities and do one of the following:

1. Click Edit > Explode
2. Click the Explode button on the edit bar
3. Right-click to show the pop-up menu, click Explode.

It is a good idea to make it a habit to explode all drawings before saving as a DFX file to convert.
Add Instructions to Drawing

Before an AutoSketch drawing can be used to stitch a pattern a few notations should be made to the drawing file. The starting point, called "first", and the ending point, called "last" must be marked on every drawing.

6.8 Adding Text

Three important things to remember about adding text to a drawing are:

1. The word "first" must be placed at the beginning of the drawing and the word "last" must be placed at the end of the drawing.
2. No portion of any text should extend outside the leftmost or rightmost boundaries of the drawing.
3. The active portion of a text entity, the lower left, should be placed directly on the line AND be between the endpoint and midpoint of the drawing entity.

6.9 First and Last

The beginning and end of a drawing are labeled as "first" and "last" respectively. When using the text tool you might find it useful to turn off all snaps. Click the Text icon to open the Text Editor screen. Type in the text you want, in this case the word "first" then click OK. The text is shown below with its selection handles.

Text can be resized and rotated in the same way you do for any other entity. The active part of a text entity is the lower left corner of the selection handles. Active means that as the program reads pattern information it starts at the active area first.

Additionally, the active area of the "first" text entity must be located between the first endpoint and the midpoint of the first drawing entity. The active area of the "last" text entity must be located between the last endpoint and the midpoint of the last drawing entity.

The three point arc shown at right contains three vertices on the line: the left, the right and the midpoint.

The picture at right shows IMPROPER placement of "first." Notice that "first" is placed between the midpoint and the last endpoint of the first entity.

The picture below shows proper placement of "first" and "last." Notice that "last" is rotated to place the active section on the line and within the drawing boundaries. The guidelines are used to make sure the text entities do not extend beyond the left and right boundaries of the pattern. If the text does extend the boundaries the drawing will still convert to a pattern, however the text will be included in the sizing, resulting in a pattern smaller than desired.
6.10 Ordering Intersections

When three or more endpoints intersect at one point the software needs to be told which direction to take at that point. The easiest way to accomplish this is to not have three or more lines end at one point.

<table>
<thead>
<tr>
<th>Line entity with its two endpoints.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Three point arc with its two endpoints and a midpoint.</td>
</tr>
<tr>
<td>This top drawing shows improper &quot;connection&quot; of one three point arc and one line. The line endpoint is connected to the arc midpoint. This causes an error in the build function. To correct this, construct the arc using two three point arc entities as shown on the right.</td>
</tr>
</tbody>
</table>

In the picture below the red dots indicate endpoints. The circle is made from two three-point arcs. All the endpoints are joined. A diagonal line is stitched first ending at the intersection of two lines and two arcs.

At this point the options are:

- Stitch clockwise over the two arcs
- Stitch counterclockwise over the two arcs,
- Stitch the second line to last.

Place a 1 on the upper arc indicating that this arc is the first to be stitched. Stitching continues around the two arcs until it reaches the intersection for a second time. The 2 indicates that the line should be stitched the second time the stitching reaches the intersection.

If a drawing is improperly ordered or not ordered at all errors occur when the file is attempted to open for stitching. One way to omit the ordering process is to construct the drawing such that the endpoints come close together without joining. The picture below shows the endpoints not connected.

The picture below is zoomed in at the intersection.

Although there is a distance between the two arcs at this point, it is so small that it appears to be connected when stitched. Turn off the endpoint snap to move the endpoints away from each other.
6.11 Snap Distance

The conversion program automatically connects endpoints that are closer together than 0.1". If you have elected to leave spaces between endpoints instead of ordering the intersection, the endpoints may automatically connect, causing conversion errors or causing the drawing to stitch incorrectly. To prevent this add the text "snap=.001" anywhere inside the drawing. This tells the computer to automatically snap endpoints that are .001" or less apart. The picture below shows the addition of the snap text.

Another useful tool of the snap function is eliminating the need for joining endpoints of entities that were created with the rubber stamp. The picture below shows five three-point arcs that were rubber stamped and placed close together.

It is time consuming to check that all endpoints are joined together and the more rubber stamped copies you have, the longer it takes. Add the snap text to the drawing to automatically snap the endpoints. In this case the only other text to add to this drawing is "first" and "last".

```
snap=.001
```
7 Files

PrecisionStitch™ uses the DXF file for stitching patterns.

- As you are preparing the drawing file you should save the files as an SKF file.
- If you want a picture file for viewing or printing, save the file as a WMF as well.
- Once the drawing is ordered, labeled and ready for use, save the file as a DXF file. More specifically, save as R12/LT2 DXF file.

The SKF file format leaves the properties of the entities intact while the DXF file format chops up each entity into smaller portions.

When errors occur as you try to open the file for stitching you will see an error screen noting the error. You should make all subsequent changes to the SKF file then save as a DXF file to be used in the next try.

You can open and edit any SKF or WMF file installed with PrecisionStitch™. Some of the files might appear as a small dot on the screen when they are opened because they were drawn to a very small scale. You can enlarge the pattern by pressing CTL-A to select it then click the View > Extent icon. The drawing fills the screen.
9 Opening Errors

As the drawing file is opened the software starts at "first" and moves forward until it reaches "last". When errors prevent a successful opening an error message is displayed. You can assume that everything on the drawing from "first" to the location of the error is correct.

Checklist for preventing conversion errors:

 “first” and “last” properly positioned on drawing
 “snap=.001” entered on drawing
 All endpoints connected
 Entities exploded before saving.

Often the error message includes the coordinates of the error location. To find the location of errors in SKF file using the error coordinates:

 On a piece of paper make a note of the location coordinates. (At this time there is no way to highlight, copy and paste the coordinates.)
 Open the SKF file, draw a straight line somewhere and select it. The status bar shows endpoint coordinates for the line.

 Highlight one set of endpoints and enter the coordinates you copied on the paper. Press Enter. The endpoint of the line jumps to the location of the error.

9.1 File Opens but Drawing is Not Correct:

Curves Turn Into Straight Lines

The picture below left shows what the pattern should look like. To the right is a picture of how it converted. All the curves turned into straight lines. Drawings should consist of individual entities such as polylines, 3-point arcs, single lines, etc.

During the drawing process one or more entities might have been grouped or joined for faster or easier drawing. The drawing should be exploded into individual entities before saving as a DXF file.

To explode a drawing, open the SKF file, select the entire drawing and click the Explode icon on the toolbar. Save the SKF file and save as a DXF file. Open the new DXF file and the pattern is correct.
**Only Part of the Drawing Opens**

The picture below right shows a good conversion but only part of the pattern was converted.

This problem occurred because the space at the bottom of the heart was smaller than .01 inches. When the conversion program finds two endpoints that are less than .01 inches apart, it snaps them together.

In this case the file was able to convert without errors but with unintended results. To solve this problem, insert the text "snap=.001" somewhere inside the drawing. This means that the program will automatically snap together two endpoints that are less than .001 inches apart.

---

**9.2 Endpoint Connection Error**

Unable to locate a connecting action near 11.1392,2.84569
Please make sure there is a connection within the distance

The endpoints are not connected at the coordinates. Check the endpoint connections and/or add the words "snap=.001" to the drawing. Save as DXF file then try to convert.

---

**9.3 Ordering Error**

Unable to figure out which action to use at location: 15.3943,2.63864
Please use more ordering information to clear this up.

Ordering information is not available at the intersection of three or more endpoints. The stitching order should be listed at this intersection telling the computer the order in which to stitch the lines. See Ordering Intersections or the Training CD for information on ordering the drawing.

---

**9.4 No "First" Error**

You must define FIRST somewhere in your drawing.
FIRST should be placed very near where you want the motion to start.

The word "first" is not located on the drawing or it is improperly located.

1. Make sure "first" is over the line somewhere between the first and middle points of the entity.

2. Another cause of this error is a line located somewhere on the drawing that is not part of the drawing.

3. Another cause is portions of the drawing around "first" are not exploded.
10 Single Patterns

Single patterns can begin or end anywhere on the drawing pad. When the DXF file is opened in PrecisionStitch™ the largest measurement, either height or width is normalized to 12". The other measurement is sized proportionately.

The checklist for completing single patterns is:

- Connect all the endpoints
- Label "first" and "last"
- Order the intersections if needed
- Add "snap=.001" if necessary

Repeat Patterns

Repeat Patterns should start and end on the same horizontal line. This keeps the pattern straight along the horizontal line as it stitches because "first" and "last" are at the same point.

"First" and "last" may be placed anywhere on the drawing as long as they are placed along the same horizontal line. Snap the "first" and "last" endpoints to a horizontal guideline to check their positions. See Using Guidelines and Editing the Drawing.

The checklist for completing multiple patterns is:

- Connect all the endpoints
- Draw a horizontal gridline and snap "first" and "last" to it
- Label "first" and "last"
- Order the intersections if needed
- Add "snap=.001" if necessary.
Alternating patterns are patterns designed to shift horizontally every other row. An example is the cloud pattern shown below.

This pattern is shown not shifted. Alternating patterns are really two different patterns that are alternately stitched in rows as shown below.

The picture below shows two repeats of row 1 pattern at the top followed by two repeats of row 2 pattern at the bottom.

The horizontal spacing between rows is 0.

1. Draw the row 1 pattern first and give it a distinctive name such as CloudRow1.SKF.
2. Choose File > Save as and save another copy of the file as CloudRow2.SKF. Edit this drawing by dividing it in half then moving the left half to the right of the right half as shown below.

To stitch alternating patterns please see Alternating Patterns in the PrecisionStitch™ User Guide.
13 No Sew Move and Pause in Pattern

13.1 Patterns
With PrecisionStitch™ you can combine two or more patterns and stitch them as one. One example is the square inside a square shown below.

To do this you connect the two squares with a dashed line to indicate that the needle is off when "stitching" that line.

Draw the designs as you normally do, making the drawing continuous and connecting the endpoints. Then change the connecting lines to dashed lines. The ordering of the intersections is the same and there is only one "first" and one "last". The drawing below is a close up of the notations for the pattern above. The dashed lines tell the software where to turn the needle off.

In this example the small square is stitched first. If the Do Tieoffs box is checked, the stitcher takes several tie stitches before moving along the dashed line to the large square. Before stitching the large square the stitcher takes several tie stitches.

To indicate which lines are "no sew" you must insert the macro below somewhere inside the drawing:

```
STOPPING_MACRO LINETYPE "NO NEEDLE OFF"
END_MACRO

STOPPING_MACRO LINETYPE "NO NEEDLE ON"
END_MACRO
```

This macro is available in a SKF file from tech support or it can be downloaded from the internet. The file name is NoSew.SKF.
If you do not have access to this file you simply insert the text as shown above and draw the solid and dashed lines on top of the text. The lines are not drawn in the text box as you type the words. You insert the text first then add the lines next.

To quickly change the connecting lines from solid to dashed use the Property Painter tool on the Standard Toolbar.

1. Click the icon and move the curser to the drawing board. The curser changes to a circle with two arrows pointed to the paint brush.
2. Click on the dashed line in the macro. The arrows point to the circle.
3. Now click on the first connecting line and the solid line changes to a dashed line.
4. Continue clicking on each connecting line to change it to a dashed line.

13.2 Text
This is also handy for connecting letters to form words:

Good Luck!

1. Choose a font that is wide, fat and bold because these are generally easier to work with. The font above is Comic Sans.
2. Use the text tool, to insert your text.
3. Select the text and right click.
4. Choose **Convert > Text Entities to Polygons**, or click the convert text icon .

5. Click the explode icon to explode each letter into individual segments.
6. You can now connect the letters and add first, last and ordering information.

The dashed, no sew lines are shown below in red. At each endpoint where you added the connecting dashed line you will need to indicate the sewing order for the lines.

![Good Luck text](image.png)

You can connect letters, words, symbols and even entire sentences all on one pattern.

13.3 Pause
You can instruct PrecisionStitch™ to pause sewing so that you can change thread color simply by placing the word pause on the first half of the line or arc you wish to pause at.

![Pause](image.png)

For the pause command to be recognized, the following macro (included in NoSew.SKF) must be inserted in the drawing:

```
STopping_MACRO pause
"NO PAUSE Please change thread color"
END_MACRO
```
15 Importing Windows™ Metafiles (WMF Files)

Windows™ metafile is a graphic file format used by Microsoft to transfer graphics between Windows applications. Both bitmap and vector graphics are supported by WMF. A variation on WMF is an extended version known as EMF. There are several ways to bring WMF files into AutoSketch. You can copy the WMF file from another program and paste into AutoSketch or you can open the WMF file as a new AutoSketch file.

This is useful for importing clip art images, quilting software images or any WMF file into AutoSketch. Most clip art software you purchase will have a program called Metafile Companion used to view an edit WMF files. Some quilt design software or other drawing programs such as CorelDraw and Adobe Illustrator have the ability to either export the drawings as Metafiles or to save the drawing as a WMF file.

Once you have the WMF file open in AutoSketch and before you can begin editing it, you need to convert the drawing for your purposes. These steps are described below.

15.1 Opening WMF files in AutoSketch

1. Choose File > Open. Under "Files of type: choose Windows Metafile (#.WMF). Browse through your files to the WMF file you wish to open. Highlight the file name and click Open.
2. The picture opens in a new file. To move the picture to your drawing template click Edit > Select> All to select the picture. Click Edit > Copy to copy the picture.
3. Continue with steps 2 – 5 above.

15.2 Copying WMF Files from Other Applications

1. After completing your drawing in the other application, select the drawing and do one of the following:
   * Choose "Export as metafile" to copy the WMF file to the clipboard, or
   * Choose Edit > Copy to copy the WMF image to the clipboard, or
   * Click File > Save as... and select the WMF file format. Click Save. The file is now in WMF format and is displayed on the screen. Select the drawing and click Edit > Copy to copy the file to the clipboard.

2. In AutoSketch click Edit > Paste Special > Picture (metafile) > OK. Place your curser somewhere on the grid and left click to place the picture on the grid.
3. With the picture still selected click Edit > Entities...
4. The Edit entities pop up appears. Click the Poly tab. You want to change the properties of the WMF file to properties you can edit for your drawing.
5. Under Polygon type choose Polyline. Under Mode choose None. Click OK. If the picture was solid before, it now changes to a line drawing containing vertices that can be edited.
16 Closed Shapes

Often when drawing patterns or editing patterns from clip art, the pattern consists of several closed shapes such as rectangles or circles. These closed polygons should be broken apart at some point so that you can order the direction and place "first" and "last" on the drawing.

**Example – Breaking and Ordering a Polygon**

The rectangle below left is closed and has four vertices.

The same rectangle is shown below right after breaking at the lower left corner. Notice the addition of the fifth vertex.

1. Using the Rectangle icon draw a rectangle.
2. Click *Edit > Trim > Break* or click the Trim Break icon. The cursor turns into a small circle.
3. Place the circle on the lower left corner of the rectangle and click. One side of the rectangle turns red. Click on the red line.
4. Use the select tool to select the rectangle. Double click the rectangle to enter edit vertices mode. The fifth vertex has been added.
5. Zoom in to the lower left corner and label the rectangle as shown below.
17 Tracing Pictures

Scanned images or other picture images such as JPG and GIF files can be brought into AutoSketch and traced to create a pattern. Scan or crop the image by including extra area outside the drawing. This makes it easier to use later in AutoSketch.

You can trace the image using Layers or tracing directly on the picture.

17.1 Using Layers

To create a new layer in a blank document:

1. Choose Tools > Graphic Options. The Graphic Options dialog box appears.
2. Click the Layer tab.
3. Enter a name for the new layer in the Layer Name text box. You might wish to call this "Photo" or something to indicate that this is the layer containing the scanned picture.
4. Click Add to add the Photo layer. To place the Photo layer in the background choose Background in the State section and click Change.
5. Choose Layer 1. To make this layer current choose Current in the State section and click Change.
6. Click Close.
7. From the blank screen choose Draw > Picture. Click and drag the mouse to designate a drawing area on the screen. The Open Picture dialog box opens.
8. Navigate to the BMP or JPG file you wish to trace and click Open.
9. You are now able to trace over the picture file.
10. After drawing is complete choose Edit > Select All and move the drawing to an open part of the screen for further editing.

17.2 Tracing Directly on the Picture

Copy the image and open a new AutoSketch file. Choose Edit>Insert Object then click on the drawing board. Click on the lower right selection handle and drag it to enlarge the picture. Zoom in very close to the part of the picture you wish to trace.

If the corners of the picture are showing on the screen and you are using endpoint snap, the entities will snap to the corners as you draw. If the corners are off the screen they have no effect as you draw. This is why you scanned or cropped a larger area that you actually need.

You might find it easier to see the design as you trace it if you color the line and/or make it thicker. On the edit bar click the Color icon to change the line color and click the Width icon to change the width of the lane. After tracing is complete delete the image you inserted and continue with the other steps for the DXF file.
18 Threading the Machine

Improper threading of the machine can result in poor stitch quality and broken threads. Refer to the manufacturers' threading diagram for your brand of quilting machine.

18.1 Gammill Quilting Machine Using Cone

1. Cone - should be level on the platform and directly under the first thread guide. If the cone is tilted, you can rotate the thread platform on the handles until the top of the cone is directly under the first thread guide. This allows the thread to unwind evenly from the cone.
2. First thread guide - should be directly above the center of the cone.
3. Thread post.
4. Intermittent Tension Device - Thread through the small post before threading clockwise through the intermittent tension device.

5. Thread Break Sensor - Thread counter clockwise around the thread break sensor.
6. Thread Guide - This guide has three holes that are threaded from the top down. It is not necessary to use all three holes. Use the first and last holes only.
7. Rotary Tension Device - Thread over the first post, clockwise around the rotary tension 1 1/2 times, over the check spring and under the second post.
8. Take-up Lever
9 - 11. Thread Guides
12. Needle - thread from front to back of machine.
18.2 Gammill Quilting Machine Using Small Spool

1. Spool - thread should unwind clockwise as shown.
2. Thread guide.
3. Intermittent Tension Device - Thread through the small post before threading clockwise through the intermittent tension device.
4. Thread Break Sensor - Thread counter clockwise around the thread break sensor.
5. Thread Guide - This guide has three holes that are threaded from the top down. It is not necessary to use all three holes. Use the first and last holes only.
6. Rotary Tension Device - Thread over the first post, clockwise around the rotary tension, over the check spring and under the second post. Gammill recommends that the thread be wound around the rotary tension 1 1/2 times, however good tension is achieved by winding only 1/2 times.
7. Take-up Lever
8. - 10. Thread Guides
11. Needle - thread from front to back of machine.
Belts should be disengaged for stitching in Constant Speed or Regulated Modes and engaged for stitching in Automatic and Record Modes. The software detects when the belts are disengaged and automatically uses the correct encoders.

19.1 Engaging the Belts

1. Standing at the rear (motor side) of the machine, move the machine to the far right of the table. Align the rear bracket with the rear X-axis set pin.
2. Insert the set pin into the bracket and tighten the wing nut.
3. On the right side of the quilting machine move the Y-axis set pin into place in the bracket and tighten the wing nut.
4. At the front of the machine, insert the set pin into the bracket and tighten the wing nut.

19.2 Disengaging the Belts

1. Standing at the rear (motor side) of the machine, move the machine to the far right of the table.
2. Under the carriage at the center back, locate the wing nut for the rear X-axis motor belt. Turn the wing nut to the left to loosen the set pin.
3. Pull the set pin down and out of the bracket on the carriage.
4. On the right side of the quilting machine locate and loosen the wing nut for the Y-axis motor belt. Pull the set pin out of the bracket and move the set pin as far to the rear of the machine as possible. This prevents the set pen from getting caught on the bracket during quilting.
5. At the front of the machine, under the carriage at the center front, locate the wing nut for the front X-axis motor belt. Turn the wing nut to the left to loosen the set pin.
6. Pull the set pin down and out of the bracket on the carriage.