Go to top

What’s New in CreativeStudio 6

What’s New with CreativeStudio® 6.0

Gammill is pleased to announce CreativeStudio® Version 6.0which is available at https://gammill.com/software-license-agreement/

The Username and Password are available on the Statler User group.
If you don’t have access to the Statler User Group, contact support at 1-866-830-3738.

This version is for Windows 7 or 8 or 8.1 computers only, Ethernet controllers (Mod A & Up) only. As Microsoft is no longer supporting XP, the latest and greatest libraries are no longer XP compliant; if we want to keep improving and making things better, we must no longer support XP. Mod 3’s will not be supported moving forward, even if they have a Win 7 PC. The latest Galil libraries require the Mod 3 to be re-chipped, and it would require inefficient code in CreativeStudio® (CS) that would greatly reduce the performance of your Mod 3. CS 4.2 will be the last version to support the Mod 3.

CreativeStudio® upgrade instructions:(Note: If you do not already have a previous CreativeStudio® version installed, go to “CreativeStudio® fresh install instructions” below.)

  • Check your firmware by opening your current CS, click Tools, Controller Definition, click 3rd tab; you will get a warning but just click Yes, in the third column, Controller Version note the letter of your 2132 firmware, it should be q4, r, r2 or greater. Example DMC2132 Rev 1.0r2 is ok. If your firmware is out of date STOP and contact Gammill at 1-866-830-3738 to order your firmware kit.
  • Download CreativeStudio6.0.zip
  • Click Start, Control Panel, Add or Remove Programs to uninstall the old version of CreativeStudio.
  • Take the downloaded file via flash drive to your Stitcher and unzip it, right click CreativeStudio 6.0 Installer.exe, click Run as Administrator.
  • Follow the CS installation directions to install on your C:\ Drive.
  • Be sure to select your Controller (MOD) Type.
  • Start CreativeStudio® and notice the introductory splash screen now indicates Version 6.0
  • Calibration now auto runs on first time startup, just position your head in the front middle of the table.
  • Under the Tools menu item, select “Controller Definition” and set your user defaults, such as SPI, etc.
  • You are now ready to run CreativeStudio®, Happy Quilting!

CreativeStudio® fresh install instructions:

  • If you have never had CreativeStudio® installed on your computer, please contact Gammill at 1-800-659-8224, ext. 213 to purchase a version 6.0 CD.
  • CreativeStudio® must be installed from a CD, at least once, because the support files needed are very large and their installation is complex.
  • The CD will auto install the many needed support files for you.

CreativeStudio®V6.0 includes many new features and contains fixes that have been brought to our attention since the release of V 5.0. Many new enhancements have been added to improve the user’s experience. These enhancements came from quilters like you. If you have additional ideas for enhancements, please send them to [email protected] Gammill and Statler are committed to the needs of the quilting community and make every attempt to improve future software versions with their needs in mind. This release has been thoroughly tested. However, should you discover a problem with our software, please report it to [email protected] Thank you.

What’s New in CreativeStudio 6.0

  • New Border Corner placing top and bottom border patterns: Now patterns can be placed in a continuous sewable order: left side patterns, corner pattern, top patterns, corner pattern, and right side patterns. If the patterns are designed to connect, this all happens without tie offs. The function does work with patterns that do not connect. We have eliminated the math and time needed to do border corner work. (See below for adding side borders)To use: Hold Control key, in the pattern list pick the corner pattern first then pick the border pattern, click the Border Corner icon, then CS will prompt you to click outer and inner boundaries.
  • New Border Corner placing side patterns relative to Quilt Length: After CS sets up the border corner and top (or bottom) pattern placement (see above), the side border patterns will be properly sized and placed on the CAD screen by entering the border length from top to bottom of the border. CS will compensate for the margins and corner patterns and then adjust the length of the side patterns to fit the quilt. The length will be as close as possible to the top border patterns. You can use the size of these side patterns for quilting the side patterns using Repeat Patterns.To use: Hold down the Control key, in the pattern list pick the corner pattern first, then pick the border pattern, click the Border Corner icon, then click outer and inner boundaries. Enter the Quilt Length and CS will calculate a properly sized side pattern. (CS can only put the side patterns in if there is enough room in the drawn boundary.)
  • New Border pieces option to connect to corners: You now have the option to connect border patterns to the border corners or to have a jump stitch between the border patterns and the corner.To Use: Setup Border Corner as instructed above, set Connect to True to connect the corner to the border patterns. Sometimes it is not desirable to connect the corner to the border, so set connect to False.
  • New measure transfer in Border Corner: To further assist with Border Corner placement, the right click measure transfer now works in this function.To Use: Measure on CAD or on the Quilt, then in Border Corner setup, right click a numeric field and pick the value you want to transfer.
  • Added user settable Thread Breaks (TB) delay: User settable TB delay from 0 to 9.00 seconds. This causes CS to ignore TBs for the user set time. Certain threads and methods are more prone to false TBs. This setting will screen those false TBs out. We saw more false TBs in CS5.0 because the new software is so much more responsive.To Use: In the menu, click Tools, Technical Support, Controller Definition, change the TB Delay (located at the end of the middle column) to reduce the sensitivity of the Thread Break. Larger value equals less responsive Thread Break. Default is 0.1.
  • New Import Image, loads image file on the CAD: Using Import Image, you can pick any JPG image to load on your CAD screen. This is useful for laying out patterns in blocks, testing pattern appearance and designing new patterns. Imagine the creative possibilities of being able to load any picture onto your CAD screen.To Use: Click the File Menu item, Import Image, browse to select any JPG image. A new quilt group is created with the image in the background.
  • New Image Opacity increases images transparency: The Image Opacity slider helps with pattern design by muting the intensity of the imported image so the pattern lines are more apparent.To Use: First follow the steps above to import the image and load that image on the CAD screen. Right click in the open CAD, click the Image Attributes menu item, move the opacity slider. Moving the slider to the far left will make it completely transparent (invisible) and the image will be completely opaque when moving the slider to the far right.
  • New Red, Green, Blue Filter slider for images: The Red, Green and Blue Filter slider helps with pattern design by only making the desired colors visible. To get familiar with how these sliders work, move both the Red and Blue to the left those colors will be filtered out completely, now notice the image appears green.To Use: First follow the steps above to import the image and load that image on the CAD screen. Right click in the open CAD, click the Image Attributes menu item, move the red, green or blue slider.
  • New Line thickness slider for pattern and boundary lines: The Line Thickness slider increases the thickness of the pattern and boundary lines. To the far left is the thinnest line (CS’s default) to the right is the thickest available.This feature helps even when an image is not on the screen by making the patterns more visible.To Use: Right click in the open CAD, click the Image Attributes menu item, move the Line Thickness slider.
  • New Export Image, makes image file of the CAD: Under File, Export Image, pick a location to store a JPG of your quilt layout. This can be used with or without an image on the CAD screen. Also useful to show your customers the planned pattern layout, and for building a portfolio of your work to show new customers.To Use: Click the File Menu item, Export Image, find a folder and pick a name for your image. The name cannot be the same file name that is being used for the background image.
  • New Point to Point (P2P) Pattern concatenation: This has been an often requested feature. You may now place multiple p2p patterns in a desired sequence. Use Ctrl to select as many p2p patterns in the pattern list as you want to use (A, B, C). You may use either the head to mark points on your quilt, or use the mouse to mark points on the CAD. The patterns will show in the order they were selected (A, B, C; A, B, C; A, B…)To Use: Add p2p patterns to the pattern list. To repeat a pattern multiple times, add that pattern to the pattern list as many time as the desired use. (Add pattern A twice to the pattern list for the example A, A, B; A, A, B…) Click your first p2p pattern in the pattern list, hold down the Control key and select the additional patterns in the order you wish to place them. Click the p2p icon and start clicking points.
  • New Apply Pattern places P2P along pattern: Now you can make one or more p2p patterns (see above to use multiple p2p patterns) follow another pattern’s lines. Apply Pattern is great for making circular arrays that connect and sew continuous. This adds a new dimension to your quilting because the P2P will curve to follow the pattern.To Use: Have the pattern (path) to be followed on CAD screen using any method, be sure the path pattern is selected. Pick one or more p2p patterns in the pattern list, set the desired height, then right click the pattern you want to follow and click the Apply icon.
  • New Node mode “F7”: Clicking F7 while a pattern is selected shows all the nodes of the pattern. Arc control nodes are shown as blue nodes. Pink nodes are endpoints and are dividable. To Use: With a pattern on the CAD selected, click F7 on the keyboard or the Node icon on the right side of the CAD screen or Right click the pattern and select Node Mode. To move a node, just hover your mouse over the node, the cursor will change to a cross, left click, hold and move the node as desired.
  • New in Node mode “D” divides the node: The Node mode (see above) provides several options to divide a pattern.To Use: In Node mode, right click a pink node and select Divide in the dialog box or hover your mouse over a pink dividable node and press “D” on the keyboard. The first and last pink nodes of a pattern will not divide.
  • New Arc control Nodes (blue) are moveable but not divisible: In Node mode (see above), Arc control nodes help to manipulate patterns in more ways. Moving the blue nodes changes the tension of the arc, which is very useful in pattern design and filling the quilting area space.To Use: In Node mode, hover over a blue node and left click, hold and move.
  • New right click Node menu: When hovering over a pink node, right click the node and a new dialog box will come up.It can be used to add Designer notes or change the speed and Stitches per Inch (SPI) while quilting. (See below)To Use: In Node Mode right click a pink node, a new ‘dialog box’ comes up.
  • New user settable Designer Notes: In Node mode (see above), the new right click node menu is a text box that contains the Macro notes associated with that node. These can be passed into CS thru Autosketch. If there is no note associated with the node, you can add it. If you start the note with the text “PAUSE”, then add your personal message, CS will stop when sewing at that node and display your personal message.To Use: In Node Mode right click a pink node, a new menu comes up, type PAUSE (all caps) then your message.
  • New Designer Node SPEED: In Node mode (see above), a new Designer Notes macro function, SPEED, will change the current speed by whatever percentage value is selected. For example, SPEED 50 will decrease the current speed by 50%, SPEED 100 will return to the previous speed. This is useful for problematic areas of patterns where more speed control is desired.To Use: In Node Mode right click a pink node, a new ‘dialog box’ comes up, type SPEED (all caps) then your percentage value (1-100).
  • New Designer Node Stitches Per Inch (SPI): In Node mode (see above), a new Designer Notes macro function, SPI, will change the current stitches per inch by whatever percentage value is selected. For example, SPI 50 will decrease the current SPI by 50%, SPI 100 will return to the previous SPI. This is useful for problematic areas of patterns where more SPI control is desired.To Use: In Node Mode right click a pink node a new ‘dialog box’ comes up, type SPI (all caps) then your percentage value (1-100).
  • Added user settable E2E Registration: In the past, E2E registration was whatever you last set and the default value was Place two Pins. After much testing and review, we have determined that End of Set is the best registration method and is the new default. The registration is now user settable and E2E will always start with your preference.To Use: In the menu, click Tools, Controller Definition, at the bottom of the middle column change the E2E Registration to your desired default value.
  • New Mirror about any two points: Mirror allows you to pick any two points on the CAD screen to mirror a second pattern. The points can be at any angle adding to the versatility of the feature.To Use: Select any pattern on the CAD screen, click the Mirror icon, CS will prompt you to pick any two points on the CAD screen.
  • New Squeeze Pattern to any shaped Boundary: A new choice under Pattern to Boundary is Squeeze. Now your boundary can be ANY shape and ANY number of sides, even curved. Your pattern will be modified to fit nearly any shape. This will greatly improve how patterns fit your boundaries and produces some truly unique patterns that are worthy of adding to your pattern library. Patterns that fill a square or rectangular shape work best. Not every pattern works well with this feature, some experimentation may be needed. To Use: Click the drop down carrot (small triangle) next to Pattern to Boundary icon, select Squeeze. Pick the boundary on the CAD screen, select a pattern in the pattern list, and click the Pattern to Boundary icon.
  • New Order Join feature automatically re -orders patterns to be continuous: This makes patterns sew continuously if possible. When done, all the patterns that were joined are selected so that you can combine them into one pattern if desired, but they are left as separate patterns to improve versatility.To Use: Right click the part of the pattern you want to sew continuously, pick Order Join or left click the pattern and select the Order Join icon on the right side of the CAD screen.CS will search if another pattern is touching the first, automatically reverse the pattern as needed and then change the patterns’ order to be sequential to the first and so on till no connection is found.
  • New Power Assist in Regulated: This has been requested by many users, but until we made the software changes in CS5.0, it was not possible. Now with the faster libraries we can bring you Power Assist in all modes, including these hand guided modes. It greatly reduces your effort to move the Stitcher. Power Assist does turn off when Channel Lock is engaged.To Use: Be sure there is a check mark next to Power Assist in the Tools Menu. Start any handguided mode, Regulated, Constant Speed or Baste, and observe the head is easier to move
  • New Recorded patterns show on the CAD: In CS 5.0, we greatly improved the Record patterns feature, this trend continues; now patterns being recorded are shown dynamically on the CAD screen as you record it. It is now possible to record patterns with the head while looking at the CAD screen instead of the quilt.To Use: Make a loose boundary around the area you plan to record (this will keep the CAD screen zoomed properly). In Regulated or Constant Speed, record your pattern with needle on or off and observe the recording is shown dynamically.

Support Improvements:
Changes to the software to improve Statler’s ability to support your Stitcher.

  • New ignoring Thread Break (TB) during Competitive Tie Off : This will eliminate false Thread Breaks during tie off. The fast tight nature of the competitive time made it more prone to false TBs. By ignoring the TB signal during a tie, we will eliminate this problem.
  • New maintain pattern selection when Quilt Group added: Usually you have whatever pattern you want to work with selected. In the past, adding a Quilt group would change that selection to the top of the project explorer, now your selection is maintained.
  • New Convert icon dings if nothing to convert: This reduces confusion by using the alert chime that is used in other places to let the user know that they have neglected to pick an object to convert.
  • New Canceling Export to CSQ or DXF now returns to idle state: If the user mistakenly activated the Export feature and cancels the Export, CS now returns to an idle state.
  • Fixed error when right clicking in E2E or BC setup
  • Fixed grid cut off issues: CAD grid could not show in certain circumstances, the fix was to click View All. This should now be fixed and the grid should always show behind your patterns.
  • Fixed Convert to Curve to make points on lines: It is more versatile to show node points on the lines.
  • New /Log History folder keeps the last 5 days of logs: This will help our support team by retaining a copy of previous logs. These all can be sent in for review of trends. In the past, CS would delete the old log when CS restarted, which eliminated the important information. Now the old log is saved stamped with the date and time.
  • Fixed short start and end in Fill: Was a Known Issue in CS5.0, it is now better than any previous version of CS.
  • Fixed corner rounding in Fill: Was a Known Issue in CS5.0, it is now better than any previous version of CS.
  • Fixed issue with Power Assist turning off: This was a sporadic issue in CS5.0. If you have given up on Power Assist, you might consider trying again in CS6.0.
  • Fixed auto save to only run in Idle mode: This should prevent the rare problem that happens when saving a project that is actively working on other things.
  • Fixed Power Assist Calibrate stop routine.
  • Fixed Crosshair to be visible on Project load.
  • Fixed icon availability issue in Setup modes.
  • Corners now showing rotation property.
  • Added catch for invalid aux encoder value.
  • Added milliseconds to log This will help our support team better gauge the performance of your system.