Go to top

CreativeStudio 7.5

Prior to Updating

Prior to updating, be sure to follow these steps to ensure a smooth process.

  1. Finish any projects you have in progress.
  2. Save projects
  3. Sync to the PatternCloud (If totals don’t match update to the latest CS)
  4. Check for Microsoft updates on your computer. Run updates until you receive the message that there are no more updates available.
  5. Try to do the update during Gammill Tech Support business hours which are now 8 a.m. to 8 p.m. central Monday through Friday and 8 a.m. to 7 p.m. central Saturday and Sunday. To reach Tech Support, call 417-256-5919.

*Current users may notice that the software is going directly from 7.3 to 7.5.  Due to significant changes to Windows that Microsoft launched through updates days before the planned launch of 7.4, CreativeStudio 7.4 was not released to the public.  7.5 has all the improvements of 7.4 as well as changes required by the Microsoft Windows updates

Please read the installation instructions and download notes below prior to download.
Using CreativeStudio in stand alone mode requires a Windows PC.

Updating your software

Updating Statler Machine

Launch the CreativeStudio program and you will receive a notification that the new update is available. Click ‘Download and Install’ to begin the process. Or, you can click ‘Service’, ‘Check for Updates’ to begin the process.

Updating for Stand Alone Mode

You can also experience the software in Stand Alone Mode. If your stand alone computer already has a version of CreativeStudio 7, use the auto update prompt. Open CreativeStudio 7 and when the prompt appears, click ‘Download and Install’ to begin the update. Or, you can click ‘Service’, ‘Check for Updates’ to begin the process.

Install Troubleshooting

Click Here for troubleshooting during updating.  If these solutions do not work for you please call tech support at 417-256-5919 and we can assist you further.

What’s New in CS 7.5

Simplified Upgrade Installation Through Check for Updates
If you use the Auto Update prompt or Check for Updates within CS to update to the latest version, because CS knows you already have a previous version of CS installed, it does not try to reinstall parts that are already there. This speeds up the update installation and eliminates some of the common installation errors such as sql errors, issues with Galil tools, etc.

SAM Mode on Stitcher Prevention
CS now detects if you are on a stitcher and prevents opening in SAM Mode. CreativeStudio now provides notification alerts to the user with detailed information about connection issues and provides troubleshooting tips.

New! Interactive Splash Screen
The latest news from Gammill will now be displayed on the splash screen.

New! Divide at All Pink Nodes
Patterns can now be divided at ALL Pink Nodes.

New and Improved Patterns!
25 border corner pattern sets have been added or improved to work better with the border corner function. Over 70 patterns have been added or improved..
*The next time you ‘Copy Free Gammill Patterns’, CreativeStudio will be updated with these changes.

New! Favorite Sync
Marking a pattern as a Favorite now syncs across devices.

Improved: Login Improvements
CreativeStudio will now keep the user logged into PatternCloud after a restart.
*Please note, you will need to log back in one time after the new software install.

Improved: Auto Turn Off of Extended Pause
CreativeStudio will now time out when the machine is left in the paused state for an extended period of time. This will prevent damage to your xy motors from being left in the paused state for an extended period of time. If timed out, the user can use Restart Quilting to begin stitching again.

Improved: Controller Definition SAM
With changes to 7.5 the SAM Controller # and SAM checkbox under Controller Definitions are no longer needed. So, they have been removed to reduce confusion.

Improved: Sync
The pattern type, tag, collection, and favorite syncing have all been improved to make syncing patterns easier and more effective.

Improved: Special Characters added
Searching for tags with special characters is now possible in CreativeStudio and PatternCloud. The added characters are &.’_-~()+

Improved: Pattern Import
Imported PATs now automatically decrypts using your registered controller. A decryption number no longer needs to be manually entered every time.

Improved: Directions for Offline Registration
If the Internet is unavailable from your stitcher, directions for how to use the Offline Registration process are now available under the Help menu.

Improved: Multi-Select to Permanently Delete
Multiple patterns can be Permanently Deleted at one time.

Improved: Prevent Free Patterns From Gammill From Being Permanently Deleted
Users are now unable to permanently delete free starter patterns. This was done so patterns that users no longer want to see in their main pattern list and that are sitting in the deleted patterns folder can’t be deleted permanently and therefore won’t reappear when new free Gammill patterns are released to Gammill owners. For example, if you delete 5 of the free patterns you do not want, they will not be reimported the next time you check for new free patterns.

Improved: Importing Deleted Patterns
If a user attempts to import patterns that are currently deleted the pattern is labeled ‘Already Deleted’ and highlighted mauve, the user may checkbox those patterns and restore the original pattern back to their main pattern folder.

Corrected: Bulk Import for Encrypted Patterns
Importing more than 18 encrypted patterns at one time is now possible.

Corrected: Patterns Tab, Right Click Pattern, Sync: Backup to Cloud
Tag and other changes are now synced to the cloud when a user right clicks and clicks “Sync: Backup to Cloud”

Corrected: Marking End of Quilt After Loading Saved E2E project.
In previous versions, if you exited CS in the middle of an E2E, when the project was re-loaded, you would not be prompted to mark the bottom of the quilt. This has been fixed.

Corrected: Regulated & Baste Keypad
Regulated or Baste causing the keypad to become unresponsive is now fixed.

Corrected: Check for Non Existent Save Project Locations
In the past if you saved a project to a USB drive and then removed that drive from your computer CS still tried to auto-save to that location. Now if the drive is no longer available CS will ask you to choose another location to ensure your project is saved.

Corrected: Blank Extra Page at End of Pattern Tab Removed
In 7.3, previously deleted patterns showed as blanks on the last pages of Pattern Manager.

Corrected: Keypad Disappearing
In the past the keypad would occasionally not be visible, those issues have been resolved.

What’s New in PatternCloud

New! Multi-Delete / Multi-Restore / Multi-Remove
It is now possible to delete, restore, or remove multiple patterns at a time. While in your pattern folder or deleted pattern folder, click “Options” then “Multi-Edit Mode” to gain access to the tools.

New! Cloud and Designer Tag Searches in User Accounts
Clicking on tags when viewing a pattern now shows all of that user’s patterns with that same tag. Also, cloud and designer tags are now also included when searching for a pattern in a user’s account.

Improved: Prevent Free Patterns From Gammill From Being Permanently Deleted
Users are now unable to permanently delete free starter patterns. This was done so patterns that users no longer want to see in their main pattern list and that are sitting in the deleted patterns folder can’t be deleted permanently and therefore won’t reappear when new free Gammill patterns are released to Gammill owners. For example, now if you delete 5 of the free patterns you don’t want, they will not be reimported the next time you check for free patterns.

Improved: Copy Starter Patterns to Account Functionality
‘Add Only’ only inserts patterns into the user’s account that were completely missing and it will not update any existing pattern properties or tags. ‘Reset’ will delete then re-add all starter patterns except those that are in the user’s deleted folder. This ensures that you have the most recent version of the patterns.

Improved: Fonts Category in User’s ‘My Patterns’ Tab
There is now a new category in PatternCloud where font groups will be stored at https://patterncloud.com/account/fonts.php. Fonts from now on will be found under this category and will no longer be mixed within the main Patterns page. They will also not be directly counted in a user’s total pattern count at the top of the main pattern page or during sync (though they will still be synced in the background). If a user deletes a pattern from a font group folder, it can be viewed and restored or permanently deleted by clicking Advanced Search, Deleted Patterns, then the Search button while in the main pattern page.

Improved: Font Group
When viewing an individual pattern of a character, which belongs to a font group, the name of the group that font belongs to will now appear alongside its Ascii and Character designation.

Improved: Importing Deleted Patterns
If a user attempts to import patterns that are currently deleted, they may check boxes for those patterns and restore the original pattern back to their main pattern folder.

Improved: Upload from Apple Devices
Apple users will now be able to upload pattern files to PatternCloud.

Improved: Upload Drag and Drop
Drag and drop from a file explorer window onto the file browse button has been implemented.

Corrected: Pattern Image Rendering
There was a bug where if something went wrong while a user attempted to upload a pattern, the website would not attempt to render the thumbnail of that pattern ever again. Now if the pattern is missing its thumbnail, the website will attempt to rerender the image whenever a page with that pattern is loaded.

Corrected: Search by Pattern Title
Certain patterns that were previously not searchable by pattern title are now searchable.

Corrected: Elevate Deleted Patterns Sync Improvement
When Elevate tablets sync, patterns that are in the user’s deleted folder are no longer included in the sync.

Corrected: Collections, Sets, and Font Groups Interaction with Deleted Patterns
Patterns that are deleted will no longer show up in the user’s Collections, Sets, or Font Groups folders and the pattern count will be corrected on their respective tiles.

Corrected: Font Corruption
Syncing Fonts to and from CreativeStudio has been improved to fix a bug where fonts would be corrupted and made unusable in the ‘Draw Text’ function of CreativeStudio.

How to use the new features 

CreativeStudio Pattern Delete Features

  • To delete a pattern: In the pattern tab, Right-click pattern and select Delete Pattern. This changes the pattern status to hidden.
  • To view and search deleted patterns: In the patterns tab, select Advanced Search, place a checkmark in Deleted in the bottom corner to view deleted patterns. To search this folder, add tags, types, and/or designers.
  • To restore patterns: Right-click on the pattern you would like to keep and select Restore Pattern. This option will now be available in the Patterns tab.
  • To permanently delete patterns: Right-click on the pattern you want to remove and select Permanently Delete Pattern. The pattern will be removed.
    *If you need to restore the pattern, you will need to import it again or sync to PatternCloud.
  • Sync Changes to PatternCloud: Click the Sync option from the patterns tab. Changes will now show in PatternCloud.
    *Note: permanently delete patterns still needs to be done in CreativeStudio and PatternCloud.

PatternCloud Delete Features

  • To delete a pattern in PatternCloud:
    Go to My Patterns > Patterns > Options > Show Delete Buttons.
    Click the Red X at the top of the pattern.
  • To view and search deleted patterns in PatternCloud:
    Go to My Patterns > Patterns > Advanced Search. Place a checkmark next to
    Deleted Patterns. Click Search My Patterns. All deleted patterns will now be visible.
  • To restore a pattern: View the deleted patterns, click Show Restore/Delete Buttons in the Options menu, and click the Green O at the top of the pattern. The pattern is now visible in My Patterns.
  • To permanently delete a pattern: View the deleted patterns, click Show Restore/Delete Buttons in the Options menu, and click the Red X at the top of the pattern. The pattern has now been removed from PatternCloud.

*Note: permanently delete patterns still needs to be done in CreativeStudio and PatternCloud.

Was this article helpful?
Dislike 11